This browser does not support basic Web standards, preventing the display of our site's intended design. May we suggest that you upgrade your browser?

Microsoft PowerPoint 2007

Adding Links

While giving your PowerPoint presentation, you have more options than simply advancing through your slides. You can create links within your presentation that will allow you to jump to another slide or presentation, open a website or file, or add automatically updating material from another program.

PowerPoint provides two ways to create links, each of which serves a different function. You can add linked objects to your presentation, which allows you to display an object that was created in another program (such as an Excel graph). When the object is updated in its original program, those changes will be reflected in the object in your presentation. You can also link objects such as text or graphics to other pages or slides, allowing you to bring up new information by clicking the link.

return to topPlacing Linked Objects

This option allows you to place a dynamically linked object, which was created in another program. The dynamic link means that when the object is updated in its native program, the linked object in your presentation is also updated. For example, a linked Excel chart in your presentation will be automatically updated whenever the spreadsheet data is updated in Excel.

In order for an object to be linked, the program used to create the original object must support object linking and embedding (OLE). All Microsoft Office programs support OLE, unless you are working in compatibility mode (e.g., OLE will not be supported if you are linking to an Excel 2003 chart in a PowerPoint 2007 presentation). OLE is the feature which allows information changed in another program (e.g., a changed chart in Excel) to be updated automatically in PowerPoint.

WARNING: If you create a link to an object, that object must be on the computer when you give your presentation. If the object is renamed, moved, or deleted, it will not be available when you give or work with the presentation.

Placing Linked Objects: Copy and Paste

This option works best when working with a graphical elements such as a chart or graph. You can place the linked object itself, or an action button or icon which will open the original program when clicked.

  1. In the program that was used to create the object, open the file containing the object
    EXAMPLE: A chart created in Excel

  2. Select all of the data that you want to link to your presentation (e.g., the chart)

  3. Right click the selection » select Copy

  4. Open your PowerPoint presentation and display the slide into which you want to insert the linked object

  5. From the Home tab, in the Clipboard group, click thePaste arrowbelow PASTE » select Paste Special...
    The Paste Special dialog box appears.

  6. Select Paste Link
    The dialog box refreshes to display the Paste Link options.

  7. In the As list, verify that the type of file that you are linking to is selected
    Past Special dialog box

  8. OPTIONAL: To display the linked object as an icon, select Display as icon
    HINTS:
    You can add a hyperlink for this icon which will open the file containing your object in the original program when you click the icon.
    When working with your presentation in Normal view, you can double click this icon to bring up the original file in its source program.

  9. Click OK
    The linked object is displayed.

Placing Linked Objects: Insert Dialog Box

This approach is most useful when placing a file such as a spreadsheet.

  1. From the Insert tab, in the Text group, click OBJECTObject button
    The Insert Object dialog box appears.

  2. Select Create from file
    The Insert Object dialog box refreshes.
    Insert Object dialog box

  3. To select a file,
    1. Click BROWSE...
      The Browse dialog box appears.
    2. Using the Look in pull-down list, navigate to and select the desired file
    3. Click OK

  4. To create the dynamic link, select Link

  5. OPTIONAL: To display the linked object as an icon, select Display as icon
    HINTS:
    You can add a hyperlink for this icon which will open the file containing your object in the original program when you click the icon.
    When working with your presentation in Normal view, you can double click this icon to bring up the original file in its source program.

  6. Click OK
    The linked object is displayed.

Updating a Link

When an object is updated in its native program, the linked object in your presentation is automatically updated.

You can also choose to open the linked object in the original application through PowerPoint.

  1. Select the linked object

  2. Right click the object » select Linked Object » Edit
    The object opens in its source program and can be edited.

  3. When finished editing the original file, save and close the file
    Your object in PowerPoint is updated.

return to topLinking to a File or Website

You can create a link that will open the application to display a specific file or website. This link can be created from text or a graphic.

  1. If necessary, from the View tab, in the Presentation Views group, click NORMALNormal button

  2. Display the slide on which you want to create a link

  3. Select the text, image, or shape which will be the link

  4. From the Insert tab, in the Links group, click HYPERLINKHyperlink button
    The Insert Hyperlink dialog box appears.

  5. In the Address text box, type the path and filename or the complete URL
    OR
    To browse for the file or web page, using the Look In pull-down list, navigate to and select the desired file

  6. Click OK

return to topLinking to Slides in the Same Presentation

You can create links to different slides within your presentation, even if the slides are hidden or would not normally be displayed next in the presentation. For example, if you have some hidden slides that contain extra material, you can link to those slides and then come back to your original slide. You can use text or any graphic as your link.

  1. Select the text, image, or shape that you want to be the link

  2. From the Insert tab, in the Links group, click HYPERLINKHyperlink button
    The Insert Hyperlink dialog box appears.

  3. From the Link to section, click PLACE IN THIS DOCUMENTPlace in This Document icon
    Insert Hyperlink dialog box: Place in This Document options

  4. In the Select a place in this document section, select the desired slide
    HINT: If you would like to link to a specific slide and the list of slides is not available, click the plus sign (+) next to Slide Titles.

  5. Click OK

Changing a Link

If you would like to change a link to open a different slide, you can do so.

  1. Right click the linked text, image, or shape » select Edit Hyperlink...
    The Edit Hyperlink dialog box appears.

  2. From the Link to section, click PLACE IN THIS DOCUMENTPlace in This Document icon

  3. From the Select a place in this document scroll list, select the desired slide
    NOTE:
    If you choose First Slide, Last Slide, Next Slide, or Previous Slide, these are relative links and may link to different slides if the order of the slides is changed or if more slides are added. To guarantee that you link to the specific slide you want, you should select a specific slide from the list.

return to topLinking to Slides in Another Presentation

It is often convenient to reference another PowerPoint presentation that provides pertinent information to your current presentation.

  1. Select the text, image, or shape you want to be the link

  2. From the Insert tab, in the Links group, click ACTIONAction button
    The Action Settings dialog box appears.

  3. Select Hyperlink to

  4. From the Hyperlink to pull-down list, select Other PowerPoint Presentation...
    The Hyperlink to Other PowerPoint Presentation dialog box appears.

  5. From the Look in pull-down list, navigate to and select the desired file

  6. Click OK
    The Hyperlink to Slide dialog box appears.

  7. Select the desired slide

  8. Click OK

  9. In the Action Settings dialog box, click OK

To return to the parent presentation during the presentation:

  1. Right-click anywhere on the slide » select Last Viewed

Excellence. Our Measure. Our Motto. Our Goal.