This browser does not support basic Web standards, preventing the display of our site's intended design. May we suggest that you upgrade your browser?

Microsoft PowerPoint 2004

Linking and Branching

During a PowerPoint presentation, there are dynamic options that extend beyond simply advancing linearly through your slides. Linking and branching are two methods that offer access to other slides, presentations, documents, or applications during your PowerPoint presentation.

Linking functions work much like a hyperlink on the Web. Linking allows you to link to websites, other PowerPoint presentations, or to objects created in other programs. For example, while giving a presentation you can link to an Excel chart with supporting data or to a website containing topical information.

Branching allows you to move to slides that are hidden in your presentation, noncontiguous, or contained in another presentation. For example, you may be on slide 5 which is related to information on slide 15. You can branch to slide 15, return to slide 5, and then continue with your presentation.

Return to Top Linking

Aesthetically, object linking adds an interesting and dynamic flare to presentations. Functionally, it eliminates the need to start and restart programs or to perform repetitive cutting and pasting during your presentation production. You can link to an object, such as an Excel chart or graph, or link to a file or website. Updating a link is easy, but objects can also be transformed from linked to embedded.

NOTE: If you create a link to an object, that object must be accessible from the computer when you give your presentation. If the object is saved on a disk, the disk must be in the computer; if the object is saved on a network drive, the drive must be mapped from the computer. If the object is renamed, moved, or deleted, it will not be available when you give or work with the presentation.

Linking to an Object

The following instructions work only when you are linking from a program that supports OLE, such as a Microsoft Office program. You can use the linked object itself, an icon, or an action button as your link.

  1. In the program that was used to create the object, open the file containing the object
    EXAMPLE: A chart created in Excel

  2. Select all of the data that you want to link to your presentation

  3. From the Edit menu, select Copy

  4. Open your PowerPoint presentation and display the slide into which you want to insert the linked object

  5. From the Edit menu, select Paste Special...
    The Paste Special dialog box appears.
    Paste Special dialog box

  6. In the Paste As listing, select the type of file that you are linking to

  7. OPTIONAL: To display the linked object as an icon, select Display as icon

  8. Click OK
    The linked object is displayed.

Linking to a File or Website

  1. Display the slide on which you want to create a link

  2. In the Normal view, select the text or object which will form the link

  3. From the Insert menu, select Hyperlink...
    The Insert Hyperlink dialog box appears.

  4. In the Link to text box, type the path and filename or the complete URL
    OR
    To locate the file,
    1. From the Document tab, click SELECT...
    2. Navigate to and select the desired file
    3. Click OPEN

  5. Click OK

Updating a Link

After an object from another program is linked from your PowerPoint presentation, changes made and saved to the object in the source program are automatically reflected in your presentation, regardless of whether PowerPoint is open. If you double-click a linked object in PowerPoint, the application that created the object will appear in its own window. You can edit the linked object in its original application and then save it; the linked object is then updated in PowerPoint.

You can also edit a linked object in the original application without having PowerPoint open. For example, you could link to an Excel chart in your presentation, but later change the data in the chart. When you save the updated version of the linked chart, your presentation files are automatically updated to reflect those changes. In order for an object to be linked, the program used to create the original object must support object linking and embedding (OLE). All Microsoft Office programs support OLE.

Changing a Linked Object to an Embedded Object

When you know you will no longer be updating a linked object, you may want to change it to an embedded object. This way, you will not need to switch between programs to alter the object’s appearance.

NOTE: Changing a linked object to an embedded object is permanent; you cannot revert to a linked object.

  1. Open the slide that contains the linked object

  2. Select the linked object

  3. To activate the Drawing toolbar, from the View menu, select Toolbars » Drawing
    The Drawing toolbar appears on the screen.

  4. From the Drawing toolbar, click DRAWDraw button» select Ungroup
    A dialog box appears warning the link will be rendered unusable.

  5. Click YES
    The object is now detached from its source file, and you may alter the object in PowerPoint.

Return to TopBranching

It is easy to branch to other slides in your presentation or to another presentation. For example, if you have some hidden slides that contain extra material, you can branch to that material and then come back to your original slide. The branching process consists of two parts: Creating a Branch and Changing your Action Settings.

Creating a Branch

You can use an action button, text, image, clip art, or other Autoshape as the source of your branch.

Creating a Branch: Using an Action Button

  1. From the Slide Show menu, select Action Buttons » select the desired action
    Your cursor becomes a cross-hair.

  2. Click and drag the mouse to shape the action button

  3. Release the mouse button
    The Action Settings dialog box appears.

  4. From the Action on click section, select Hyperlink to

  5. From the Hyperlink to pull-down list, select Slide...
    HINT: To guarantee that you link to the specific slide you want, you should use the Slide option. Next Slide, Previous, First, Last, or Last Slide Viewed are relative links and will not always link as you intended.
    The Hyperlink To Slide dialog box appears.

  6. Select the desired slide

  7. Click OK

  8. In the Action Settings dialog box, click OK
    An action button appears on the slide.

Creating a Branch: Using Text

  1. Select the text you want to be the branch

  2. From the Slide Show menu, select Action Settings...
    The Action Settings dialog box appears.

  3. From the Action on click section, select Hyperlink to

  4. From the Hyperlink to pull-down list, select Slide...
    HINT: To guarantee that you link to the specific slide you want, you should use the Slide option. Next Slide, Previous, First, Last, or Last Slide Viewed are relative links and will not always link as you intended.
    The Hyperlink To Slide dialog box appears.

  5. Select the desired slide

  6. Click OK

  7. In the Action Settings dialog box, click OK
    The linked text appears underlined.

Creating a Branch: Using an Image

  1. Select the image or shape you want to be the branch

  2. From the Slide Show menu, select Action Settings...
    The Action Settings dialog box appears.

  3. From the Action on click section, select Hyperlink to

  4. From the Hyperlink to pull-down list, select Slide...
    HINT: To guarantee that you link to the specific slide you want, you should use the Slide option. Next Slide, Previous, First, Last, or Last Slide Viewed are relative links and will not always link as you intended.
    The Hyperlink To Slide dialog box appears.

  5. Select the desired slide

  6. Click OK

  7. In the Action Settings dialog box, click OK
    The selected image is linked.

Changing your Action Settings

After you have branched to a specific slide, you may decide that you want to change the branch root or destination. To edit a text or object's branching options, you must modify the action settings.

  1. Press [ctrl] and click on the branched object » select Action Settings...
    The Action Settings dialog box appears.

  2. From the Hyperlink to pull-down list, select Slide...
    HINT: To guarantee that you link to the specific slide you want, you should use the Slide option. Next Slide, Previous, First, Last, or Last Slide Viewed are relative links and will not always link as you intended.
    The Hyperlink To Slide dialog box appears.

  3. Select the desired slide

  4. Click OK

  5. In the Action Settings dialog box, click OK
    The new settings will apply to the branch.

Return to TopBranching to Another Presentation

It is often convenient to reference another PowerPoint presentation that provides pertinent information to your current presentation.

  1. Select the text, image, or shape you want to be the source of the branch

  2. From the Slide Show menu, select Action Settings...
    The Action Settings dialog box appears.

  3. From the Action on click section, select Hyperlink to

  4. From the Hyperlink to pull-down list, select Other PowerPoint Presentation...
    The Choose a File dialog box appears.

  5. Navigate to and select the desired file

  6. Click OK
    The Hyperlink To Slide dialog box appears.

  7. Select the desired slide

  8. Click OK

  9. In the Action Settings dialog box, click OK

To return to the parent presentation during the presentation:

  1. Press [control] and click the mouse » select End Show

Excellence. Our Measure. Our Motto. Our Goal.