This browser does not support basic Web standards, preventing the display of our site's intended design. May we suggest that you upgrade your browser?

Microsoft PowerPoint 2003

Linking and Branching

While giving your PowerPoint presentation, you have more options than simply advancing through your slides. Linking and branching are two PowerPoint options that offer access to other slides, presentations, documents or applications.

Linking, much like a hyperlink on the Web, allows you to link to websites, other PowerPoint presentations, or to objects created in other programs. For example, while giving a presentation, you can link to an Excel chart with data that supports your point or to a website which contains information related to your topic.

Branching allows you to move to slides which are hidden in your presentation, are noncontiguous, or are contained in another presentation. For example, you may be on slide 5, which is related to information on slide 15. You can branch to slide 15, return to slide 5, and then continue with your presentation.

return to topLinking

Object linking eliminates having to start and restart programs, or having to perform repetitive cutting and pasting. After an object from another program (e.g., a chart from Excel) is linked from your PowerPoint presentation, changes made and saved to the object in the source program (e.g., Excel) are shown in your presentation automatically, regardless of whether PowerPoint is open. For example, if you link to an Excel chart, when the chart is modified it will be reflected in your presentation. In order for an object to be linked, the program used to create the original object must support object linking and embedding (OLE). All Microsoft Office programs support OLE.

NOTE: If you create a link to an object, that object must be on the computer when you give your presentation. If the object is renamed, moved, or deleted, it will not be available when you give or work with the presentation.

Linking to an Object

The following instructions work only when you are linking from a program that supports OLE. Other Microsoft Office programs support OLE. You can use the linked object itself, an icon, or an action button as your link.

To create a link using the linked object:

  1. In the program that was used to create the object, open the file containing the object
    EXAMPLE: A chart created in Excel

  2. Select all of the data that you want to link to your presentation

  3. From the Edit menu, select Copy

  4. Open your PowerPoint presentation and display the slide into which you want to insert the linked object

  5. From the Edit menu, select Paste Special...
    The Paste Special dialog box appears.

  6. Select Paste Link

  7. In the As list, verify that the type of file that you are linking to is selected
    Past Special dialog box

  8. OPTIONAL: To display the linked object as an icon, select Display as icon

  9. Click OK
    The linked object is displayed.

Linking to a File or Website

  1. Display the slide on which you want to create a link

  2. In the Normal view, from the Slides tab, select the text or object which will be the link

  3. From the Insert menu, select Hyperlink...
    The Insert Hyperlink dialog box appears.

  4. In the Address text box, type the path and filename or the complete URL
    OR
    To locate the file or web page, from the Look In pull-down list, navigate to and select the desired file

  5. Click OK

Updating a Link

If you double-click a linked object in PowerPoint, the application that created the object will appear in its own window. You can edit the linked object in its original application and then save it; the linked object is then updated in PowerPoint. You can also edit a linked object in the original application without PowerPoint being open. When you save the linked object, presentation files are automatically updated.

Changing a Linked Object to an Embedded Object

When you know you will no longer be updating a linked object, you may want to change it to an embedded object. This way, you will not need to switch between programs to alter the object’s appearance.

NOTE: Changing a linked object to an embedded object is permanent; you cannot revert to a linked object.

  1. Open the slide that contains the linked object

  2. Select the linked object

  3. On the Drawing toolbar, from the Draw pull-down list, select Ungroup
    A dialog box appears warning that if the object is changed the link will be unusable. 

  4. Click YES
    You may now alter the object in PowerPoint.

return to topBranching

It’s easy to branch to other slides in your presentation or to another presentation. For example, if you have some hidden slides that contain extra material, you can branch to that material and then come back to your original slide. You can use an action button, text, clip art, or other Autoshape as your branch.

To create a branch using an action button:

  1. From the Slide Show menu, select Action Buttons » [desired action]

  2. Draw the action button on your slide by clicking and dragging with the mouse

  3. Release the mouse button
    The Action Settings dialog box appears.

  4. Select Hyperlink to

  5. From the Hyperlink to pull-down list, select the desired slide
    HINT: To choose from a list of all of your slides, select Slide... and then the desired slide.
    NOTE: If you choose Next slide, Previous, First, Last, or Last slide viewed these are relative links. To guarantee that you link to the specific slide you want, you should use the Slide... option.

  6. Click OK

To create a branch using text:

  1. Select the text you want to be the branch

  2. From the Slide Show menu, select Action Settings...
    The Action Settings dialog box appears.

  3. Select Hyperlink to

  4. From the Hyperlink to pull-down list, select the desired slide
    HINT: To choose from a list of all of your slides, select Slide... and then the desired slide.

  5. Click OK

To create a branch using clip art or other AutoShapes:

  1. Select the image or shape you want to be the branch

  2. From the Slide Show menu, select Action Settings...
    The Action Settings dialog box appears.

  3. Select Hyperlink to

  4. From the Hyperlink to pull-down list, select the desired slide
    HINT: To choose from a list of all of your slides, select Slide... and then the desired slide.

  5. Click OK

To change your action settings:

  1. Right click the action button » select Action Settings
    The Action Settings dialog box appears.

  2. From the Hyperlink to pull-down list, select the desired slide
    HINT: To choose from a list of all of your slides, select Slide... and then the desired slide.
    NOTE: If you choose Next slide, Previous, First, Last, or Last slide viewed these are relative links. To guarantee that you link to the specific slide you want, you should use the Slide... option.

return to topBranching to Another Presentation

It is often convenient to reference another PowerPoint presentation that provides pertinent information to your current presentation.

  1. Select the text, image, or shape you want to be the branch

  2. From the Slide Show menu, select Action Settings...
    The Action Settings dialog box appears.

  3. Select Hyperlink to

  4. From the Hyperlink to pull-down list, select Other PowerPoint Presentation...
    The Hyperlink to Other PowerPoint Presentation dialog box appears.

  5. From the Look in pull-down list, navigate to and select the desired file

  6. Click OK
    The Hyperlink to Slide dialog box appears.

  7. Select the desired slide

  8. Click OK

  9. In the Action Settings dialog box, click OK

To return to the parent presentation during the presentation:

  1. Right-click anywhere on the slide
    A Quick menu appears.

  2. Select End Show

Excellence. Our Measure. Our Motto. Our Goal.