This browser does not support basic Web standards, preventing the display of our site's intended design. May we suggest that you upgrade your browser?

HTML Coding

Image Maps: Working with ImageMapper for the Macintosh

Note: The HTML pages are out-of-date and will not be updated.

ImageMapper is a Macintosh software program for image mapping.

return to topAbout ImageMapper

ImageMapper provides many features to make creating image maps easier. With ImageMapper you can do the following:

return to topWorking with ImageMapper

Getting Started

  1. Open ImageMapper

  2. From the File menu, select Open Graphic

  3. Select the graphic file that will be used for the image map
    ImageMapper will automatically create the mapping file (example: graphic.m).

  4. From the Toolbar dialog box, select the drawing tool of your choice and then enclose an area on the graphic to be the "hot spot"

  5. In the Object Editor dialog box, select the Target tab and type the URL for the "hot spot"

  6. Select the Tags tab and type a name for the ALT field and the Target field (for your reference only)

  7. Repeat steps 4-6 as necessary

Resizing Hot Spots

  1. Select the pointer tool

  2. To select the area you want to resize, click in that area
    NOTE: An outline and drag handles will appear around the "hot spot" area

  3. To resize, drag a handle

Moving Hot Spots

  1. Click and hold in the middle of the "hot spot"

  2. Drag to a new location

  3. Release the mouse button

Saving the Image File

  1. From the File menu, select Save
    ImageMapper will save the graphic and a file with the mapping coordinates called "markers" with an ".m" extension.
    NOTE: This is not the same as the mapping file you need to operate images. In order to create the mapping file, you must generate the file as text.

Generating the File as Text

To generate the text (mapping) file, decide whether you want to create a client side or a server side image map

For client side image maps:

  1. From the Image menu, select Generate Image Map...

  2. Select Client-Side HTML

  3. Click COMPILE

  4. In the Generate HTML dialog box, in the appropriate fields, type the filename, title, and alternative text
    NOTE: ImageMapper may automatically enter the filename, title, and alternative text in the fields provided, but you can change these.

  5. Click GENERATE
    ImageMapper will open a window that allows you to view the file.

  6. To save the HTML file, in the upper left corner, click SAVE

For server side image maps:

  1. From the Image menu, select Generate Image Map...

  2. Select NCSA or CERN

  3. Click EDIT

  4. In the Generation Parameters dialog box, in the Header Comment field, you can type what you would like to appear as the header
    NOTE: ImageMapper may automatically enter a header but you can override it.

  5. Click APPLY

  6. In the ImageMapper Compiler dialog box, click COMPILE
    ImageMapper will bring the file up in an HTML editor.

  7. In the upper left corner, click SAVE
    A save dialog box will appear.

  8. In the highlighted field, type the filename, then click SAVE

return to topAdditional Notes

The following points regard server side image maps.

Referencing the Mapping File
When referring to the mapping file in your HTML document, link to the file with the ".map" extension.

Uploading the Mapping File
When you upload the mapping file (.map) to the server, it is critical that the file is uploaded as RAW DATA.

Excellence. Our Measure. Our Motto. Our Goal.