This browser does not support basic Web standards, preventing the display of our site's intended design. May we suggest that you upgrade your browser?

HTML Coding

Converting Documents for HTML Editing

Note: The HTML pages are out-of-date and will not be updated.

As you are planning your Web site and preparing to create your Web pages, you may discover that the information already exists in an electronic form -- often in your word processor. You do not have to retype the text to get it into a Web page. You can either save the files as "text only" and add all the code yourself or use an HTML converter to do the initial coding for you.

return to topSaving As Text Only

In order to move text that already exists in a file into a Web editor, you can either copy it from the original program and paste it into a Web editor document, or save the information in a "text only" or "ASCII" file that your Web editor can read. Almost every word processor (and many other programs) have the ability to save files as "text only." When moving your information to a text only file, make sure you have a backup of the original file.

When you are working with a file that has been saved as "text only," you will need to add all of the HTML code to the document.

Word for Windows (6.0 or 7.0): Saving as Text Only

  1. Open the document you want to make into a Web document

  2. From the File menu, select Save As

  3. From the Save File as Type pull down menu, select Text Only with Line Breaks (*.txt)

  4. In the File Name text box, type a new name for the file
    Word will automatically add a TXT extension to the file if you do not enter an extension.

  5. Click SAVE

WordPerfect for Windows (5.x or 6.x): Saving as Text Only

  1. Open the document you want to make into a Web document

  2. From the File menu, select Save As

  3. From the File Type pull down menu, select ASCII Text

  4. In the File Name text box, type a new name for the file

  5. Click SAVE

Word for the Macintosh (5.1 or 6.0): Saving as Text Only

  1. Open the document you want to make into a Web document

  2. From the File menu, select Save As

  3. From the Save File as Type pull down menu, select Text Only with Line Breaks

  4. In the Save Current Document As text box, type a new name for the file

  5. Click SAVE

PageMaker (Macintosh or Windows, 4.x or 5.x)

  1. Open the document you want to make into a Web document

  2. From the Toolbox, click the A button to select the Text tool

  3. Set the insertion point within the text story you want to work with

  4. From the File menu, select Export
    The Export dialog box will appear.

  5. In the text box above the File Format list, type the name for the file

  6. From the File Format list, scroll down to select Text Only

  7. Click OK

SWP (B-20 Users): Saving as Text Only

It is possible to convert SWP files to a DOS file that can be used as a basis for your Web documents.

Moving Text Only/ASCII file into Web Editor

Once you have your document in the "text only" format, you are ready to move the information into your Web Editor for coding.

  1. Open your Web Editor

  2. Open the "text only" file

  3. Select all of the text in the file

  4. From the Edit menu, select Copy

  5. Close the file

  6. Open the file (e.g., new document, template, or existing document) you want to add the text to

  7. Place your insertion point where you want the text to be

  8. From the Edit menu, select Paste

  9. Begin formatting the text with HTML code

return to topUsing HTML Converters

HTML Converters are available for some popular programs including Word 6 and 7 for Windows and the WordPerfect 6.x for Windows. Converters for PowerPoint, Lotus, and Excel are also available. New versions of some software come with the HTML converter as a standard part of the package. Converters for older versions of some software packages are available to download from the Internet.

Converters can be powerful tools for adding HTML code to your document. Like Web Publishing and HTML Editors, converters are still being developed and fine-tuned. Using a converter for some documents, generally documents with simple formatting, can save you time formatting. However, when converting more complex documents, using a converter may create more work as you may have clean up the code that the converter "thought" you wanted. If you are interested in exploring converters, we encourage you to try it out with several documents before determining whether or not it is a good decision for you. You may find that the converter works great for some documents!

A site with converters:

Basics of Using a Converter

This process of using a converter will be different depending on what software you are using. However, this process basically consists of saving your document in HTML format. Once you have opened your file, save the document as HTML by changing the file type to HTML. The process may be somewhat similar to the following instructions:

  1. Open the document that you want to convert

  2. From the File menu, select Save As

  3. From the Save File as Type pull down menu, select HTML

  4. In the File Name text box, type a new name for the file

  5. Click SAVE / OK

Working with your Converted Document in Your Web Editor

Once you have the document converted, you are ready to preview it with your browser or move it into your Web Editor for fine tuning.

Previewing:

  1. Open your Web Browser (i.e., Netscape, Internet Explorer)

  2. From the File menu, select Open File

  3. Locate and select the converted file

  4. Click OK

  5. Review the file
    If necessary, continue with Fine Tuning in Your Web Editor.

Fine Tuning in Your Web Editor

Once you have your document converted you are ready to fine-tune the code. The process will be similar to adding the code to a text-only file. The primary difference is that you may need to "clean up" some code. When deleting code from the file, make sure that you delete both on and off codes.

  1. Open your Web Editor and Browser

  2. In your Web Editor, open the converted file

  3. To do a preview in your browser and determine what needs to be corrected, from the toolbar, click PREVIEW,
    OR
    From the File menu, select Preview Document.

  4. Make the appropriate changes to the code

Excellence. Our Measure. Our Motto. Our Goal.