This browser does not support basic Web standards, preventing the display of our site's intended design. May we suggest that you upgrade your browser?

Adobe Dreamweaver CS3

Templates: Creating Templates

The first step in using templates is creating the template shell (i.e., blank template). After the shell is created, the next step is to create the page layout by adding regions and content.

return to topCreating a New Template

Creating a new template is similar to creating a new web page.

  1. From the File menu, select New...
    The New Document dialog box appears.
    New Document dialog box: Blank Template

  2. From the Category list, select Blank Template

  3. From the Template Type list, select HTML Template

  4. OPTIONAL: From the Layout list, select the desired page layout

  5. Click CREATE
    The new template appears.

return to topAdding a Region to a Template

Template regions allow you to choose what content is on each page as well as whether the content is editable. For more information on template regions, see Templates: An Overview.
NOTES:
All templates must include at least one editable region.
If you have not created an editable region in your template, Dreamweaver will prompt you to do so with a warning box before you save or close the newly created template.

  1. Place the insertion point on the line where you would like the region to appear

  2. From the Insert menu, select Template Objects » Editable Region
    The New Editable Region dialog box appears.
    New Editable Region dialog box

  3. In the Name text box, type a name for the template region

  4. OPTIONAL: If available, select other options as desired
    NOTE: Certain template regions are customizable and offer more options than others.

  5. Click OK
    The template region is inserted.

  6. Add content as desired

  7. Repeat steps 1-6 as you create the layout of your template

return to topSaving Your Template

After creating your template, you will want to save it; this will allow you to create pages with a similar look and keep your pages consistent.

  1. From the File menu, select Save
    The Save As Template dialog box appears.
    Save As Template dialog box

  2. From the Site pull-down list, select the associated site

  3. In the Save as text box, type a name for your template

  4. Click SAVE
    A Templates folder is created and your template is saved in it. Templates have a .dwt extension.

Excellence. Our Measure. Our Motto. Our Goal.