This browser does not support basic Web standards, preventing the display of our site's intended design. May we suggest that you upgrade your browser?

Microsoft Word 2004

Mail Merge: Working with the Data Source

For a successful Mail Merge, you will need to establish a recipient list, also referred to as the data source. This contains the information that will vary with each record, such as names or identification numbers. If you are creating a mailing list, for example, names and addresses will be included in your data source. 

You can either create a new data source or use a pre-existing source. You may also wish to alter the entries in your data source without having to open it, change the appropriate entries, and then save the changes. Mail Merge allows you to specify which individual entries you want to include, as well as add and delete data document entries and fields. This document covers the following topics:

For more information on the data source, refer to The Data Merge Manager: An Overview.

return to topCreating a New Data Source

After selecting the main document type, creating a new data source is the second step when using the Data Merge Manager. Before creating the data source, take a moment to plan out the information you want to include. While creating your data source, you can add or remove fields to suit your needs.

  1. If the Data Merge Manager is not displayed, from the Tools menu, select Data Merge Manager

  2. In the Data Merge Manager, in the Data Source section, click GET DATA » select New Data Source...
    The Create Data Source dialog box appears.

  3. To remove unnecessary fields,
    1. In the Field names in header row scroll box, select the field
    2. Click REMOVE FIELD NAME

  4. To add a field,
    1. In the Field name text box, type a name for the new field
      NOTE: The name must contain letters and numbers only, no other characters.
    2. Click ADD FIELD NAME

  5. To change the location of a field within the list
    1. In the Field names in header row scroll box, select the field
    2. Click the up or down arrows

  6. When you have all of the desired fields for your data source, click OK
    The Save Data Source dialog box appears.

  7. In the Save As text box, type a name for the data source

  8. Using the Where pull-down list, select the save location

  9. Click SAVE
    The Data Form dialog box appears.

  10. Type the information for each record of the Data Source
    HINTS:
    To move to the next field , press [tab]
    To move to a previous field, press [shift] + [tab]
    To add the next record, click ADD NEW

  11. When finished typing the Data Source, click OK

return to topEditing the Data Source

You can add, edit, or delete records even after you have merged the data and main documents. For the changes to take effect, however, you will have to re-merge the documents. If you want to create a new data document, refer to Creating a New Data Source.

Accessing the Data Source

  1. Open the main document

  2. If the Data Merge Manager is not displayed, from the Tools menu, select Data Merge Manager

  3. In the Data Merge Manager, in the Data Source section, click EDIT DATA SOURCEEdit Data Source button
    The Data Form dialog box appears.

Adding a Record

  1. Access the Data Source

  2. Click ADD NEW
    If you previously had four records, the number shown in Record should change to five.

  3. Type the new record information

  4. Repeat steps 2 and 3 as necessary

  5. To save the new information, click OK

Deleting a Record

  1. Access the Data Source

  2. In the Record section of the Data Form dialog box, click the buttons to display the record you want to delete

  3. Click DELETE

  4. Repeat steps 2 and 3 as necessary

  5. To save the Data Source, click OK

return to topAdding and Deleting Data Document Fields

You can add field names or delete field names even after you have merged the data and main documents.

Adding Fields

  1. Access the Data Source

  2. In the Data Form dialog box, click VIEW SOURCE
    Your data table appears.

  3. With the insertion point, select the last column (or any other column where you would like another column added)

  4. From the Table menu, select Insert » Columns to the Left or Columns to the Right

  5. In the header row of the new column, type the new field name

  6. To save the change, from the File menu, select Save

  7. To add data to the new field for each record, refer to Editing the Data Source

  8. To add the new field to your main document,
    1. From the Window menu, select the main document
    2. Position the insertion point where you want to insert the new field name
    3. From the Merge Field section of the Data Merger Manager, drag and drop the new data field into your main document

Deleting Fields

If you delete a field, the data in the field is also deleted.

  1. Access the Data Source

  2. In the Data Form dialog box, click VIEW SOURCE

  3. Select the column that you want deleted

  4. From the Table menu, select Delete » Columns

  5. To save the change, from the File menu, select Save

  6. To delete the field from your main document,
    1. From the Window menu, select the main document
    2. In the main document, select the field name
    3. Press [delete]

return to topSelecting a New Data Source

The same main document may be used with different data sources. For example, you may make a list for different committees or organizations. Each document may have only one data source at a time. If you wish to merge your main document with a new data source, you must select the new data source and replace the old one. You simply use the New Data Source command in the Data Merge Manager to select the data source to be merged with the main document.

  1. Open the main document file

  2. If the Data Merge Manager is not displayed, from the Tools menu, select Data Merge Manager
    The Data Merge Manager appears.

  3. To create a new data source, in the Data Source section, click GET DATA » select New Data Source...
    Follow the Creating a New Data Source instructions.
    OR
    To select an existing data source,
    1. Click GET DATA » select Open Data Source
      The Choose a File dialog box appears.
    2. Navigate to and select the file that contains the data
    3. Click OPEN
      NOTE: When you have more than one data source for a main document, you simply select the data source you want to merge with by using the Get Data menu to select the data file.

Excellence. Our Measure. Our Motto. Our Goal.